Author Topic: High Quality Graphics Settings  (Read 2306 times)

0 Members and 1 Guest are viewing this topic.

MightyMouth

  • eqnl
  • *
  • Posts: 807
  • Karma: +17/-4
    • View Profile
High Quality Graphics Settings
« on: December 31, 2011, 12:02:28 PM »
Hi All,

If you have played SWTOR you may have noticed that the graphics option in game leave a lot to be desired and there is no AA settings at all. Well after reading a lot of post on various forums I have found what I think are the best settings possible. If you have a graphics card around the GTX560 level or better then you should get playable framerates.

Open up your client_settings.ini which in Windows 7 is located at C:\Users\(Your Username)\AppData\Local\SWTOR\swtor\settings\client_settings.ini - If you are using XP I think its located in  C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic\swtor\retailclient\client_settings.ini If you can't find it then you probably shouldn't be messing with .ini files anyway :)

So open up the file in your favourite text editor (I prefer Notepad++ but Notepad works fine) and remove everything in the renderer section and copy/paste the following:

For Nvidia Cards
Code: [Select]
Height = 1050 (change to your Monitors Native Height Resolution and remove this text)
Width = 1680 (change to your Monitors Native Width Resolution and remove this text)
WindowX = 0
WindowY = 0
DynamicLightsLimit = 4
MeshLODQuality = 1
TextureAnisotropy = 16
FarClipScale = 3.9371195
PlantDensity = 150
D3DFullScreen = true
NativeHeight = 1050 (change to your Monitors Native Height Resolution and remove this text)
NativeWidth = 1680 (change to your Monitors Native Width Resolution and remove this text)
doShadows = true
doBlobShadows = false
UseMinSpecShaders = false
EnableBloom = true
VerticalSyncState = true
AntiAliasingLevel = 16
FullScreen = true
TextureQuality = 0
AllowDepthOfField = true
GammaRamp = 1.037854
SpeedTreeDistanceScale = 1.25
enableadvenvirolighting = true
DebugAdvEnviroLighting = true

Or if you are using An AMD/ATI Card

Code: [Select]
Height = 1050 (change to your Monitors Native Height Resolution and remove this text)
Width = 1680 (change to your Monitors Native Width Resolution and remove this text)
WindowX = 0
WindowY = 0
DynamicLightsLimit = 4
MeshLODQuality = 1
TextureAnisotropy = 16
FarClipScale = 3.9371195
PlantDensity = 150
D3DFullScreen = true
NativeHeight = 1050 (change to your Monitors Native Height Resolution and remove this text)
NativeWidth = 1680 (change to your Monitors Native Width Resolution and remove this text)
doShadows = true
doBlobShadows = false
UseMinSpecShaders = false
EnableBloom = true
VerticalSyncState = true
FullScreen = true
TextureQuality = 0
AllowDepthOfField = true
GammaRamp = 1.037854
SpeedTreeDistanceScale = 1.25
enableadvenvirolighting = true
DebugAdvEnviroLighting = true

With ATI Cards the AA settings don't work so have been removed from the above and you have to go into your Global graphics card settings and set your AA quality there.

Now save the file and set the file to Read Only by right clicking, select properties and tick the read only box.
Remember that if in the future Bioware enable these settings in game to remove the read only flag otherwise settings in game will not be saved.

Hope this is helpful to someone.